개인 자료란 (JE)

  서버 커뮤니티

Profile 코코냐 전문해결사

NeoForge 29b36732d56749ccbee1ca4729ea258b

Profile

자료 공통 리뷰, 강좌 기초

[Java Runtime] 런타임을 교체해보자!

2022.06.04 조회 수 13797 추천 수 0

::: 이게 왜 필요하죠? :::

마인크래프트를 실행하다 보면 갑자기 실행이 안되면서 런타임 설정을 확인하라는 문구가 표시될 때가 있습니다.

이럴 때는 런타임을 수동으로 변경해주어야 할 수 있습니다.

::: 하는 법 :::

자바 설치는 다른 강좌를 참조해주세요.

[ 자바 설치 강좌 바로가기 ]

당연하지만, 1.17 이상은 자바 16+, 미만은 자바 8을 사용해야합니다.


우선, 런쳐의 설치 설정에서 수정할 프로필을 누른 뒤, 설정 더 보기를 누릅니다.


그 다음, JAVA 실행 파일 오른쪽의 찾아보기를 누릅니다.


설치해둔 자바의 경로로 들어가, javaw.exe를 선택합니다.
(경로는 보통 C드라이브 > Program Files > Java > 설치하신 자바 폴더 > bin > javaw.exe 입니다)


자동으로 자바 경로가 입력되며, 해당 자바를 사용하게 됩니다.

경로를 알고있는 경우, 해당 경로를 수동으로 적어도 됩니다.


::: 변경해도 실행이 안돼요 (1.16 미만) :::

자바 8에서 일정 버전을 넘어가면 왜인지 실행이 안된다는 보고가 있습니다.

8u311로 다시 설치해주세요.




6개의 댓글

프리루트
2022.06.04

자바 버전별로 다운로드 하는 방법을 다루는 문서 링크도 관련 내용에 같이 넣으면 좋을거 같아요!

https://www.koreaminecraft.net/review/2701979

코코냐
2022.06.05
@프리루트

ㅇㅁㅇ 있군요

이거랑 똑같이 했는데

Java 런타임이 호환되지 않습니다. 내장 Java 런타임을 사용하려면 설치 설정을 수정하세요.

이름: Java version mismatch

URL: https://aka.ms/jnierror

이라고 뜨면서 실행이 안되요

코코냐
2023.11.12
@마크하고싶은사람

당연하지만, 1.17 이상은 자바 16+, 미만은 자바 8을 사용해야합니다.

버전 맞추셨냐요?

@코코냐

네 버전은 1.18.1 입니다

코코냐
2023.11.12
@마크하고싶은사람

설정 내용 찍어서 질문챗에 올려주세요

뉴스 및 창작물
/files/thumbnails/762/770/003/262x150.crop.jpg?20240418073724

레드스톤

T.B.H (고민중독) | 노트블럭 버전 | NoteBlock Cover [한국어 영어 중국어 가사 추가]

노트블럭전문가

2024-04-18

0

/files/thumbnails/218/767/003/262x150.crop.jpg?20240412130213

레드스톤

우리의 꿈 - 원피스 오프닝

노트블럭전문가

2024-04-12

0

/files/thumbnails/505/766/003/262x150.crop.jpg?20240411122306

레드스톤

기동전사 건담 수성의 마녀 | 노트블럭 커버 1

노트블럭전문가

2024-04-11

1

/files/thumbnails/932/765/003/262x150.crop.jpg?20240410124459

레드스톤

마인크래프트 노트블록으로 만든 『 밤양갱 (Bam Yang Gang) 』

노트블럭전문가

2024-04-10

0

/files/thumbnails/403/765/003/262x150.crop.jpg?20240409190538

레드스톤

마인크래프트 노트블록으로 만든 『 밤양갱 (Bam Yang Gang) 』

Sonttukk

2024-04-09

4