개인 자료란 (JE)

  서버 커뮤니티

Profile 피어 정품인증자

xphere07 c3ea982b498a411abce2ea58d83587bf

Profile

강좌 자바 에디션(JE) 모드 기초

마인크래프트 1.19.2 Fabric 및 Forge에서 OptiFine 실행하기

2021.12.07 조회 수 12763 추천 수 1
장르 (모드) 최적화 
게임버전 1.16.x, 1.17.x, 1.18.x, 1.19.x 
모드로더 포지, 패브릭 

1.15.2이나 그 이하의 버전은 이곳을 참조해주세요! 


마인크래프트 1.19 Fabric 및 Forge에서 OptiFine을 실행하는 방법입니다. 유용하게 사용해 주시면 감사하겠습니다^^


방법:


Fabric 

※ Fabric을 설치하는 방법은 이곳을 참조해주세요.

1. Fabric을 설치한다. 그리고 반드시 한 번 실행시켜준다.

2. Fabric API(대부분의 Fabric 모드는 모두들 알다시피 이 API를 반드시 필요로 합니다)를 모드 디렉터리 안에 넣는다.

3. optifine.net/downloads에서 OptiFine을 다운로드한다.

4. 파일을 실행시켜 %APPDATA%\[Fabric 실행 경로]\mods 디렉터리 안에 출력 파일이 위치되도록 한다.

5. curseforge.com/minecraft/mc-mods/optifabric/files에서 *OptiFabric를 다운로드한 다음 모드 디렉터리 안에 넣는다.

6. 모두 완료되었으면 Fabric을 실행한다.


Forge

※ Forge을 설치하는 방법은 이곳을 참조해주세요.

 1. Forge를 설치한다(가급적 최신 버전으로 해주시는 게 좋습니다). 그리고 반드시 한 번 실행시켜준다.

2. Fabric의 3번과 동일.

3. %APPDATA%\.minecraft\shaderpacks 디렉터리에 파일을 넣은 뒤 파일을 실행시켜 Extract 단추를 누른다.

5. 모두 완료되었으면 Forge를 실행한다.


추가) Forge용 OptiFine에서 충돌이 발생한 경우, OptiFine 모드 파일을 모드 디렉터리 바깥으로 빼내신 다음 파일을 실행하여 설치를 진행하신 다음, 마인크래프트 런처 프로필에 OptiFine 단독 프로필이 적용된 것을 확인하셨다면 그대로 OptiForge만 내장되어 있는 상태로 Forge를 실행하여 주시기 바랍니다.


참고: 겉으로는 옵티파인이 적용되지 않은 것처럼 보이지만 메인 화면 좌측 하단을 보시거나 설정에 들어가면 적용되어 있는 것을 확인할 수 있으며 FPS 상승, 최적화 상세 설정, 텍스처 연결 및 셰이더 등과 같은 모든 기능은 정상적으로 동작합니다!


끝. 참 쉽죠?


*OptiFabric는 마인크래프트에서 옵티파인과 패브릭이 서로 호환되게 해주는 모드입니다. 이것 외에는 영향을 미치지 않습니다.


※ 혹시 옵티파인이 제대로 적용이 안 되었거나 충돌이 발생하는 등 문제가 발생하는 등의 모르는 것들이 있거나 최신 정보가 아닌 것이 있다면 댓글로 부탁드립니다.

이 자료는 최신 업데이트가 발표될 때마다 주기적으로 업데이트됩니다.




11개의 댓글

화린
2021.12.09

The game crashed whilst unexpected error

Error: java.lang.RuntimeException: Mixin transformation of net.minecraft.class_6850 failed

Exit Code: -1

게임서버 접속시 갑자기 이렇게뜨며 게임이 팅기는 현상이 발생합니다.

마크버젼 1.18 패브릭 및 옵티파인모드도 1.18 버전에 맞는거구요

옵티파인api 및 옵티파인 파일을 mod 폴더에서 삭제후 실행시 기존 모드들과 함께 잘 돌아갑니다.

피어
2021.12.09
@화린

혹시 다른 렌더링 최적화 모드가 같이 설치돼 있나요? 예시로 리튬(Lithium)이나 소듐(Sodium), 또는 포스포어(Phosphor) 등의 모드는 옵티파인과 호환되지 않습니다.

설치된 다른 모드 목록을 모두 알려주신다면 해결 방법을 알아보겠습니다.

위치하젤
2022.03.18

패브릭 1.18.2는 옵피패브릭 호환이 안 되는 거 같네요

피어
2022.03.19
@위치하젤

네 새 옵티패브릭이 나올 때까지 기다려야 될 듯합니다

피어
2022.03.28
@위치하젤

새 옵티패브릭 버전이 이제 출시되었으니 한번 시도해 보세요

지리시
2022.03.20

무한 로딩현상이 발생합니다 혹시몰라서 옵티패블릭 빼면 접속하면 들어가지더라고요 무엇이 문제일까요?? 저는 1.18.1 로 모든 버전 똑같이 다운했습니다.

피어
2022.03.20
@지리시

OptiFine 1.18.1 HD U H5을 사용하다 오류가 발생하신 경우에는 H4 버전으로 다시 시도해보시기 바랍니다.

12313
2022.05.26
@지리시

저도 똑같은데 혹시 해결하셨나요?

xxgfgdgdg
2022.09.08

Incompatible mod set!

net.fabricmc.loader.impl.FormattedException: Mod resolution encountered an incompatible mod set!

A potential solution has been determined:

- Replace 'Minecraft' (minecraft) 1.19.2 with version 1.18-beta.1, version 1.18 or version 1.18.1.

Unmet dependency listing:

- Mod 'Fabric API' (fabric) 0.44.0+1.18 requires any version between 1.18-alpha.21.37.a (inclusive) and 1.19- (exclusive) of 'Minecraft' (minecraft), but only the wrong version is present: 1.19.2!

- Mod 'OptiFabric' (optifabric) 1.12.10 requires version 1.16.1, version 1.16.2, version 1.16.3, version 1.16.4, version 1.16.5, version 1.17-alpha.21.8.b, version 1.17-beta.4, version 1.17, version 1.17.1, version 1.18-beta.1, version 1.18 or version 1.18.1 of 'Minecraft' (minecraft), but only the wrong version is present: 1.19.2!

at net.fabricmc.loader.impl.FabricLoaderImpl.load(FabricLoaderImpl.java:190)

at net.fabricmc.loader.impl.launch.knot.Knot.init(Knot.java:148)

at net.fabricmc.loader.impl.launch.knot.Knot.launch(Knot.java:68)

at net.fabricmc.loader.impl.launch.knot.KnotClient.main(KnotClient.java:23)

오류 코드:1 충돌사유:호환되지 않는 세트 버전:마크 1.19,패브릭 0.60 패브릭 로더14.9

xxgfgdgdg
2022.09.08
@xxgfgdgdg

제발 도움좀 참고로 맥유저 입니다

피어
2022.09.09
@xxgfgdgdg

OptiFabric 버전이 1.12.10인가 보네요. 위 링크에서 최신 버전인 1.13.16을 내려받아 해당 파일로 바꿔보세요.

그리고 Fabric API 버전도 다시 한 번 확인해 보시길 바랍니다. 아래는 0.60.0이라고 쓰여 있는데 로그에는 0.44.0으로 떠 있네요?

뉴스 및 창작물
/files/thumbnails/713/360/003/262x150.crop.jpg?20221207000217

업데이트

마인크래프트 1.19.3 릴리스 후보 2 업데이트

마리오군

2022-12-06

0

/files/thumbnails/623/359/003/262x150.crop.jpg?20221205053724

업데이트

마인크래프트 1.19.3 릴리스 후보 1 업데이트

마리오군

2022-12-05

0

/files/thumbnails/159/359/003/262x150.crop.jpg?20221204203900

업데이트

마인크래프트 프리뷰 및 베타 1.19.60.20 업데이트

Dalsu

2022-12-04

0

/files/thumbnails/028/357/003/262x150.crop.jpg?20221203151725

업데이트

마인크래프트 베드락 에디션 1.19.50 업데이트

Dalsu

2022-12-03

0

/files/thumbnails/336/355/003/262x150.crop.jpg?20221130174334

해외반응

번역) 꿀팁 : 나뭇잎은 물이 얼게 하는걸 막습니다. 1

teara

2022-11-30

1

/files/thumbnails/213/355/003/262x150.crop.jpg?20221205055727

업데이트

마인크래프트 1.19.3 프리릴리스 3 업데이트

마리오군

2022-11-30

0

/files/thumbnails/100/355/003/262x150.crop.jpg?20221130071036

소식

새로운 기본 스킨들을 소개합니다 (애니메이션 영상)

프리루트

2022-11-30

0

/files/thumbnails/728/352/003/262x150.crop.jpg?20221127060715

소식

현재 엔비디아 최신 드라이버에서 마인크래프트 구버전 플레이가 불가능합니다 3

코코냐

2022-11-27

4