개인 자료란 (JE)

  서버 커뮤니티

한국 마인크래프트 포럼

마인크래프트 자료 및 커뮤니티 플랫폼

전체 회원수 127,679명 ( +90명 )

※ 장기간 미활동 회원 제외

Profile roa9618 대표칭호 없음

roa9618 abf6f3e8f8c74484917f9b816bc5ff06

Profile

커뮤니티new 개발자란new 개발 질문new Java

플러그인 제작 시 다중 버전 지원?

18 일 전 조회 수 83 추천 수 1
분야 플러그인 
API 버킷 

bukkit,spigot 플러그인 제작하는것을 연습하고 있습니다.

다른 개발자분이 배포하신 플러그인들을 보면 1.17.1 이렇게 한 버전만 지원하는 것이 아닌 1.12 ~ 1.17.1 이런 식으로 다중 버전으로 지원하는 것을 보았습니다.

1.17 이전 버전과 1.17 이후 버전은 사용하는 jdk 버전도 다른거로 알고있는데 플러그인을 제작할 때 다중 버전 지원은 어떻게 하는건지 궁금합니다.


3개의 댓글

레몬카라멜
12 일 전

JDK 8, 최소 지원 버전 기준으로 작성하시면 됩니다. 중간에 최신 버전의 메소드를 사용해야 할 경우 리플렉션이나 다른 방법을 사용해야 할 수도 있습니다.

+ plugin.yml에 api-version은 1.13으로 두시면 됩니다.

서재형
18 일 전

그냥 jdk 16에서 플긴을 만들면 1.17을 포함한 웬만한 버젼은 다 지원이 될 거에요. 버젼이 바뀌면서 달라지는점은 1.14부터만있는 CustomModelData, 1.13부터 바뀐 Material 이름, 특정 버젼부터 생긴 아이템/몹 등을 제외하면 거의 없어서, 1.17기준으로 플긴을 만들면 대부분 지원이 될 거에요.

허두
17 일 전
@서재형

근데 jdk 16에서는 jdk 8로 컴파일된(class version 52) jar파일 인식 못하지 않아요?

컨텐츠
https://www.koreaminecraft.net/files/thumbnails/952/941/002/262x150.crop.jpg?20211128203943

답안지

한마탐 수능 / 등급컷 + 해설 8

베개냥이

2021-11-25

2

https://www.koreaminecraft.net/files/thumbnails/670/940/002/262x150.crop.jpg?20211124215847

답안지

한마탐 5주차 / 정오표 + 해설 1

베개냥이

2021-11-24

2

https://www.koreaminecraft.net/files/thumbnails/133/938/002/262x150.crop.jpg?20211123001841
마인크래프트로 만든 움직이는 루디브리엄 3

LittleCharlotte

2021-11-22

8